eclipse android plug ongelma

Ongelma: Täysin uusi eclipse + android pluginin kanssa ei anna luoda uutta Android Application Projektia (Valittaa että API 18 ei ole tuettu, eikä ilmoita mitä APIa haluaa)
Eclipse ei ilmeisesti tunnista Android-sdks:n työkaluja, jolloin
Windows:

1) lataa paketti http://dl-ssl.google.com/android/repository/tools_r22-windows.zip

2) pura paketti

3) mene Android-asennuskansioosi, poista kansio Tools
ja kopioi juuri purkamasi kansio tilalle

Linux:

1) lataa seuraava paketti http://dl-ssl.google.com/android/repository/tools_r22-linux.zip

2) pura paketti kotihakemistoosi

3) avaa komentokehote ja aja seuraavat komennot:
rm -R ~/android-sdks/tools
cp -R tools/ android-sdks/

Lähde: http://stackoverflow.com/questions/18879132/install-dependencies-unsupported-template-dependency-upgrade-your-android-ecli

Mainokset

About Krister Holmström

Opiskelen Haaga-Heliassa Tietojenkäsittelyn koulutusohjelmassa. Kerään kotitehtäviini ja projekteihin liittyviä raportteja ja materiaaleja blogiini, jotta tieto olisi helpommin saatavilla.

Vastaa

Täytä tietosi alle tai klikkaa kuvaketta kirjautuaksesi sisään:

WordPress.com-logo

Olet kommentoimassa WordPress.com -tilin nimissä. Log Out /  Muuta )

Google photo

Olet kommentoimassa Google -tilin nimissä. Log Out /  Muuta )

Twitter-kuva

Olet kommentoimassa Twitter -tilin nimissä. Log Out /  Muuta )

Facebook-kuva

Olet kommentoimassa Facebook -tilin nimissä. Log Out /  Muuta )

Muodostetaan yhteyttä palveluun %s

%d bloggers like this: